WayForums

This topic contains 182 replies, has 74 voices, and was last updated by  Sorsha-WF 5 months, 2 weeks ago.

  • Author
    Posts
  • #13165

    Pryer-WF
    Administrator

    Hey Everyone! I’m going through the reports and we’re looking into or already have fixes in for some of the issues you have been listing!

    Game Crashes when adjusting keybindings (keyboard and controller).

    Thank you everyone that has reported this! This will not be occurring in the final product!

    Game crashed for me when I die trying to out run a Centipede thingy when I touched a skeleton who jumped on me.

    @miquelfire – We are looking into this, thank you!

    I’m loving the game so far! And I’m not sure if it’s a glitch, or if I just suck at video games, but after I go down and get the Monkey Shot powerup, I can’t seem to get back up to exit the room. I assume it has something to do with the powerup, but I can’t for the life of me figure out what I’m supposed to do, or if it’s just not working.

    @yasahiro – You will need to use the newly acquired ability (Monkey Bullet) to get out of the area. To use Monkey Bullet, cling to a wall and face away then press the attack button. I hope that helps!

    NPC’s in my game are not showing up/are invisible, this happened with
    the ammo baron but now I need to find a guy near the waterfall for
    some reason and he isnt there

    @rosenakahara – When/where did you notice an issue with Ammo Baron? The characters sometimes move locations but I’m not sure if that is what you encountered or not however the NPC I believe you are looking for in Mermaid Falls is actually special – you will only see him when you’ve entered his location. You can find him by searching the areas you can reach now with your newest Magic Form.

    Secondly, looking at the button remap screen I can see that
    interacting has it’s own button, B on my Xbox controller, but I can
    interact with NPCs with both X and B.

    @khtugg – That is intended functionality, you can interact using two buttons (X or B) and also cast Magic using two buttons (B or RT) [using the standard Xbox controls for this example].

    My one incident with glitches isn’t quite as bad as some of the other
    folks here, but when I used the teleport dance in the first part of
    Main Street, it continued to play the music from the first part
    instead of moving to the next part’s music.

    @lorley – Thanks!

    I want to report an out of bound glitch in the last part of Tassel
    Town. If you fly under the door to the boss it is possible to be out
    of bounds and basically get stuck there unless you teleport somewhere
    else.

    @eloyas – Thanks!

    #13188

    Khtugg
    Forwardist

    @pryer-wf – Oh, all right.

    There’s one more thing I’d like to point out: When I first booted up the demo the audio was really loud(compared to my other games) so I reduced the volume to suit me better. But every time I boot up the game the audio is really loud until I select my save. I dare not have my earphones on when “Shantae” is spoken! When I exit from playing to the start menu the sound does not default to loud, but becomes loud again on new boot up.

    It’s not worse than I just put on the ‘phones after I have selected the save, but I wanted to let you know anyways.

    #13189

    auxy
    Forwardist

    I guess we’re doing bug reports here?

    Very poor performance in early access release

    #13193

    Celtic_Minstrel
    Forwardist

    Apart from the crash when trying to change controls (which is particularly annoying since I really don’t like the default mapping) and some occasional performance hiccups (as I mentioned in this thread for the demo), I’ve noticed a few minor issues, and some little things that may or may not be issues but are not entirely satisfying.

    • I can’t skip past the boss title by pressing Escape or similar. At least I can skip cutscenes though (I found that out entirely by accident).
    • In some cases, where the game indicates the key you need to press to perform some action, it shows controller-based keys rather than the actual assigned keys. I noticed this at the file select menu and also on the magic metre in-game.
    • The world map is confusing – it’s not obvious which Shantae will move when you press an arrow key.
    • I noticed that the menus don’t wrap – for example, pressing down at the last entry does not select the first entry. Maybe this is intentional, but for me it’s kind of unintuitive.
    • I’m not sure if this is intentional, but it’s possible to get stuck in quicksand to the point that jumping does nothing to help you escape, and your only way out is to sink and respawn.

    I only got to the second Tassel Town area, but I’m liking it so far. (The fact that blocks don’t move back after you respawn kind of gives a minor advantage though in said second area). The return of pikeballs and fireballs is very welcome. The dance system seems good, though I didn’t realize it would cycle through options by holding D longer (required for warp dance, for instance), until I accidentally did so.

    #13195

    firedragonsage88
    Forwardist

    I have another crash to report. While Rottytops was in town, I went to the Main Street to look for a ticket. I got to the part you smack the crate towards the wall to get up. As I went to jump on it the screen froze, then went black (might have went to desktop, my desktop is plain black), but the music was still playing, and making a heart get sound (or something) repeatedly. The music was still playing. I was using a controller, but I hit esc on the keyboard after this happened and I could hear the menu come up.

    Had to crtl+alt+del to end process.

    That’s all I’ve got!

    #13197

    gamemjoe
    Forwardist

    Alright, so, I’ve noticed a major issue with asset loading ingame: namely, the fact that the first time I play a level, the level’s assets load fine, but on a replay, the background assets and lighting don’t load at all (barring Scuttle Town Streets and Scuttle Town itself, which load fine), leaving me staring at untextured blackness in the background. The foreground assets load fine, by the way. This glitch happens regardless of whether I’m using my 980 to play or the onboard graphics. I’ve already tried to verify the game’s files, and it did nothing to help. Please fix this, it’s very annoying to walk into these formerly beautiful levels and see that half the art hasn’t loaded.

    Here’s an example from Mermaid Falls:

    Glitchiness

    And another from Tassel Town:

    Glitchiness 2: Electric Boogaloo

    As well, I’ve noticed a glitch concerning graphical artifacts (Green/white pixelated lines and globs) that pop up every 30 minutes when playing on my 980 (and I’m sure it’s the game causing this because those artifacts don’t pop up in any other game). So, making sure that the game plays nice with Nvidia’s GPUs would also be a nice fix.

    Specs:

    GPU: GTX 980

    CPU: Intel i7 6820HK

    RAM: 32 GB

    #13199

    Tarot_The_Card
    Forwardist

    Here is what I’ve found.

    • Trying to play the game without an internet connection instantly crashes the game before the title screen, not sure if this is intentional

    • During the second phase of the final boss fight you are unable to backdash (you just backdash in place) but you can backdash during the final phase.

    #13205

    Lorley
    Forwardist

    There seem to be some visual glitches with the dance animations, particularly after I bought the Metronome. I haven’t been able to properly duplicate it at will, but it feels like it happens most often when it’s the first time you dance after entering an area.

    #13224

    Lorley
    Forwardist

    I’ve experienced two minor issues in the final boss area, so spoilers ahead

    First, before fighting the Tinkerbrain, Risky says “Time to show you Final Phase of my plan!” Kinda missing a “the” in there.

    Second, when I attack a genie while they’re charging an attack, they don’t turn into an energy ball, but just the glowing space around it. This is purely a visual bug, as they can still be whipped as if they had become an energy ball. This happens regardless of whether or not you have the Magic Inverter.

    spoilers end here

    #13234

    app1ejack
    Forwardist

    Found a Tassle Tower elephant charge glitch while ago, but haven’t been able to reproduce aside from the second time.

    I restarted the game/changed the resolution to see if that was the issue (occasionally I see some quick graphical issues while I’m playing), and I wasn’t able to do it again.

    https://www.twitch.tv/teh_app1/v/105340293

    (Also, I may just not able to recall, but is that an unused area?)

    #13240

    gb7zone
    Forwardist

    Ammo Barons’ ship. If you enter this screen from the right side (The Treasure Room door with the pool and waterfalls) and accidentally touch one of these lasers, the camera glitches out between both of the rooms and stops oin the screen shown (third image), couldn’t move but the Warp Whistle worked still and fixed the camera.

    1st

    2nd

    3rd (glitch)

    #13243

    Blazeymix
    Forwardist

    Hello. I’ve been getting crashes while swimming in the Factory as the crab transformation. Each crash was near the same location(Where you must break the rock as the elephant). Three times in a row this happened, I can’t progress further in the story because of it!

    #13244

    Flotilla
    Forwardist

    Reporting a few issues here as well:

    • The lava/spike area of Risky’s Hideout has no ceilings in many places, allowing you to skip large segments (like the monkey platforming segments, or the two spike blocks revolving in a square pattern) as Harpy Shantae.
    • The second part of Hypno Baron’s Castle can be completely ignored by going into Bat form on a moving platform, waiting for the platform to move to its highest point, and flying above every obstacle in the entire level. Introducing some solid obstacles at ceiling level could fix this, maybe?
    • A pipe in the underwater part of Tassel Town doesn’t trigger a loading screen. When you leave it, all the assets of Tassle Town try to load in real time, which results in lots of ugly pop-in. Here’s a pic of it:

    enter image description here

    #13254

    Khtugg
    Forwardist

    I’ve encountered the same issue as gamemjoe, levels look superb when first entered but subsequently turn dark and drab in the background… until now I thought it was a feature!

    Nvidia GeForce GTX 970
    gpu: 4gigabyte vram

    ram: 8 gigabyte DDR3

    Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz 4.00 GHz

    #13272

    sfried
    Forwardist

    Game crashes-to-desktop when trying to remap button controls for Controller under Options menu. This is really serious considering I use a Mayflash Adapter and a Wii U Pro Controller, and its necessary to flip some buttons around.

You must be logged in to reply to this topic.

Account Login

Enter your username or e-mail and password to login.

Forgot your password?

Register an Account

Sign up now for the good stuff.

Strength indicator

The password should be at least eight characters long and include one or more numbers. To make it stronger, use upper and lower case letters, numbers and symbols like ! " ? $ % ^ & ).

Password Reset (Step 1 of 2)

Enter your username or e-mail to reset your password. For security reasons the password reset link is sent only to the e-mail linked with your account. If you're having trouble resetting your password please contact support.

Password Reset (Step 2 of 2)